Get in touch
Back
Resolved

Dexcom Service Outage

Started 18 Jul at 04:00pm PDT.

Core
Created

Dexcom services are returning to normal and we are monitoring the situation.

Posted 18 Jul at 04:00pm PDT.